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Site Modeling and Non-Corridor Modeling

The intent of this course is to demonstrate how to turn 2D elements into 3D elements by adding profiles and elevations to civil elements that 
are typically found outside the limits of a roadway corridor (i.e. civil sites, building pads, parking lots, ponds, infield grading, bridge abutment 
grading, etc.)

In this course you are going to learn how to create 3D elements (or features) and Proposed Terrains using fundamental site modeling and 
non-corridor modeling techniques. We will utilize the vertical geometry tools along with linear templates and the terrain modeling tools 
throughout this course. 

In the first part of the course you are going to learn how to grade a cell tower site that is made up of a tower pad, yard and driveway. The 
second part of the course you will learn how to create an infield pond between corridors.

Skills Taught
 Designing and modeling a simple site 

 Modeling a pond between corridors

 Assigning elevation to horizontal geometry elements

 Draping elements relative to the existing ground

 Projecting slopes from and to elements

 Using Linear Templates for grading

 Creating terrain models from elements

 Creating combined terrain models

 Analyzing slopes and elevations



Exercise 1: Create Cell Tower Pad and Yard

In this exercise, you will learn to start OpenRoads Designer, select the proper WorkSpace & WorkSet, and Create the Cell Tower Pad and 
Yard.

Skills Taught
 Start OpenRoads Designer

 Select WorkSpace & WorkSet

 Create Cell Tower Pad using Profile From Surface tool

 Create Cell Tower Yard using Profile By Slope From Element

 Create Terrain Model

 Create Linear Template

 Apply Surface Template
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Start OpenRoads Designer

In this section, you will start OpenRoads Designer, set the proper workspace and open the cell tower site layout

1. Start the software.

2. Set the WorkSpace and WorkSet

The WorkSpace and WorkSet define standards that are used by the software. The WorkSpace and WorkSet used for this training are 
installed during the software installation.

a. Select Training and Examples from the WorkSpace menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet menu.

3. Open Grading-Cell Tower Site.dgn [Metric-Grading-Cell Tower Site.dgn]

a. Select Browse

b. Browse to c:\Bentley Training\Site Modeling and Non-Corridor Modeling or other folder where you unzipped the dataset files.

c. Select the file named Grading-Cell Tower Site.dgn [Metric-Grading-Cell Tower Site.dgn].

d. Left click Open
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Cell Tower Site Layout

In the first part of this course we are going to investigate how to grade and create a 3D model of a simple cell tower site using site modeling 
techniques. We will focus on using vertical geometry tools, linear templates and terrain modeling tools to accomplish this task. The 2D Cell 
Tower Site Layout is shown below and should be used for reference. All horizontal elements were created with the civil geometry tools and are 
intelligent ruled graphics.
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Create the Tower Pad

The cell tower pad will be placed 4.0 feet [1.2 m] above the existing ground terrain. We will use the Profile from Surface tool to generate a 
profile for the tower pad whose elevations will be determined by draping onto a surface and then offset vertically 4.0 feet [1.2 m] above the 
surface. Civil geometry can be draped onto a terrain model, a mesh, or mesh solid. 

Profile from Surface generates a profile whose elevations are determined by draping elements onto a surface such as terrain model, mesh or 
mesh solid. The tool has a variety of profile options for draping elements to and from a terrain model. Once a profile is created it is displayed 
in the Profile Model view and associated to the horizontal element. The profile can also be edited in the properties dialog, the OpenRoads 
Model and the Profile Model (view). When a profile is edited, geometric relationships are held, so if the terrain model used for draping 
changes, the profile will update accordingly.

1. Create the Profile for the Tower Pad

a. Select Geometry > Vertical > Profile Creation > Profile from Surface

b. Set the Feature Definition to Linear\Site\Site_Pad  and set the Name to Tower Pad

c. Follow the heads up prompts (after each prompt, Left click to accept values and move to the next prompt):

 Locate First Element to Profile: Select the tower pad

 Locate Next Element to Profile - Reset To Complete: Right click

 Locate Reference Surface - Reset for Active Terrain Model: Right click

 Start Distance - <Alt> Lock To Start: Press <ALT> to lock to start

 End Distance - <Alt> Lock To End: Press <ALT> to lock to end

 Point Selection: All

 Profile Adjustment: Maximum (this option will find the maximum existing ground elevation along the element and uses this value 
for the elevations of all the vertices to make the adjustment)

 Draping Option: Triangles

 Horizontal Offset: 0.00, Press <Enter> to lock the value

 Vertical Offset: 4.0 [1.2], Press <Enter> to lock the value
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2. Left click in View 4 to make it the active view (A profile model for the Tower Pad horizontal element has already been created).

A Profile Model is a 2D Model owned by a horizontal element (or feature) in this case the Tower Pad element. It can contain any number 
of elements (it will accept graphics, text, etc.). 

3. Select Fit View

Notice in View 4, the profile for the tower pad is now created and displayed. 

 When using the Profile From Surface tool a profile gets created and associated (or ruled) to the chosen horizontal element. To display 
the profile feature in the 3D model you must set the profile as the Active Profile. 

 There can be many profiles displayed in the Profile Model (for alternatives, for example), but there can be only one Active Profile. 

 The Active Profile, along the horizontal element, creates the 3D Feature. You must have an Active Profile for grading and other 
purposes. 
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4. Set the Tower Pad profile as the Active Profile

a. In view 4, select the Tower Pad profile element and hover your cursor over the profile until the context sensitive menu appears.

b. Select Set As Active Profile

Notice in View 2 the 3D feature of the tower pad appears.

Note: Some tools set their resulting Profile as Active while some do not. It is absolutely critical that you confirm in the 3D view that you get 
what you expect. If you don't see the 3D feature, the most common reason is that the tool made a profile but didn't make it active.

5. Review the Tower Pad Profile Properties

a. Select the Tower Pad profile element. Note the dynamic text shows the 4’ [1.2 m] vertical offset that was used to create the profile.

b. Hover your cursor over the profile until the context sensitive menu appears

c. Select Properties

d. The Tower Pad Profile Properties dialog will appear. Any profile adjustments can be made within this 
dialog. Notice, the bottom portion of the dialog shows the settings and rules that were used when this 
profile was created. Changing any of the settings will update the profile and the 3D feature 
automatically.
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Create the Tower Yard Profile

Next, we need to project a -1% slope away from the tower pad (in all directions) to the tower yard perimeter to establish the elevations 
of the tower yard area. We will use the Profile By Slope from Element which allows you to project a constant slope from one element to 
another.

1. Open Profile Model

a. Select Geometry > Vertical > Open Profile Model

b. Select the Tower Yard feature

c. Left click in View 4 to open the profile model for the Tower Yard feature (The existing ground profile should be displayed).

d. Left Click in View 1 to make it active.

2. Create Tower Yard Profile by projecting a -1% slope from the Tower Pad element to the Tower Yard element

a. Select Geometry > Vertical > Element Profiles > Profile By Slope From Element

b. Follow the heads up prompts (after each prompt, Left click to accept values and move to the next prompt):

 Feature: Linear\Site\Site Yard

 Name: Tower Yard

 Locate First Element to Profile: Select the tower yard feature

 Locate Next Element to Profile - Reset To Complete: Right click

 Locate Reference Element: Select the tower pad feature

 Slope: -1.0% Press <Enter> to lock the value

 Point Selection: All

 Profile Adjustment: None

 Vertical Offset: 0
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3. Select the newly created profile in View 4 and hover your cursor over the profile until the context menu appears.

4. Select Set As Active Profile to assign the profile to the tower yard element.

The tower yard 3D feature will now be displayed in the 3D Model. 



Copyright © 2019 Bentley Systems, Incorporated 11DO NOT DISTRIBUTE - Printing for student use is permitted

Create Terrain Model for the Tower Yard

Now that we have created the Tower Pad and Tower Yard 3D features we can create a terrain model that we will use to analyze cut 
and fill volumes. Terrain models are always created in the 3D model. The elements that define the terrain model can be selected in 2D 
(if a profile has been assigned to them) or selected in 3D. Terrain models allow us to see contours and slopes, calculate volumes, 
apply material depth and layers, and can be shown in profiles and cross sections of other elements.

1. Create the Terrain Model for the Tower Yard

a. Select Terrain > Create > From Elements

b. Follow the heads up prompts (after each prompt, Left click to accept values and move to the next prompt):

 Feature Definition: Terrain\Proposed\Proposed Drainage 
Contours

 Name: Tower Yard

 Locate Element to Add: Select the Tower Yard feature

 Locate Next Element to Add: Reset

 Feature Type: Breakline

 Edge Method: None

2. Add the Tower Pad feature as a Breakline

a. Select Terrain > Edit > Feature Management > Add Features

b. Locate Terrain Model to Add Elements: Select the Tower Yard terrain model from View 2 in the 3D Model.

c. Locate Element To Add: Select the Tower Pad feature in View 1.

d. Locate Next Element to Add - Reset When Done: Right click or Reset to complete.

e. Feature Type: Breakline

The terrain model is now created in the 3D model. The 3D features and terrain model contours are displayed in the 3D model. 
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Important things to note about creating terrain models from elements:

 2D elements CAN be selected in the 2D model and used in the creation of the terrain model as long as a profile is defined with the 
2D elements.

 3D elements CAN be selected in the 3D model and also used in the creation of the terrain model.

 Rules and relationships exist between the terrain model and the base elements used to create it. If the elements change, the 
terrain will update.

If at any time you need to change the display of the terrain model to view Triangles, Spots, Breaklines, Boundary, etc. you can use the 
Properties to do this.

3. Select the terrain model contours in the 3D model, hover your cursor over any contour line until the context menu appears.

4. Select Properties.

When the terrain model properties window appears, experiment with turning the contours off and turning 
on the Triangles by adjusting the On/Off settings in the middle portion of the dialog.

5. Experiment with changing the Feature Definition assigned to the terrain and notice how the terrain model 
display changes depending on which Feature Definition is chosen.

6. Set the Feature Definition back to Terrain\Proposed\Proposed Drainage Contours when finished 
experimenting.
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Tip: Sometimes it’s necessary to adjust the terrain model stroking definition values to increase or decrease the accuracy of the terrain 
model along linear elements, curves and profiles. 

 To review or modify the stroking definition values select an element that is part of the terrain model in 2D or 3D. Then select Home > 
Primary > Properties to access the full properties of the element. This will give you access to all of the element properties as well as 
the Stroking Definition where adjustments can be made. 

 The default Stroking Definition values are defined with the following configuration variables in the workspace.

7. Verify the -1% slope of the tower yard terrain using the Analyze Point tool.

a. Select the Terrain > Analysis > Points > Analyze Point 
tool to Analyze Elevation and Slope of a point within 
the terrain model.

b. Select Terrain Model Element: In the 3D Model, select 
any contour line outside of the tower pad.

c. Move your cursor into the 2D model anywhere inside 
of the Tower Yard. 

Notice the slope and elevation will display and 
dynamically change as you move your cursor.

d. Left click anywhere inside of the terrain to place the 
slope and elevation text.
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Create Tower Yard Slope Grading with Linear Templates

In this section, you will learn how to do the grading around the perimeter of the tower yard using linear templates. The Apply Linear 
Template tool applies a Template from the template library along civil geometry elements. In order to apply the linear template the civil 
geometry must have a profile associated with it. Linear Templates are useful for such tasks as grading around building pads, parking 
lots, ponds, bridge abutments and intersections.

1. Open the template library (.itl) and review the slope grading template that we will use to create the tower yard slope grading.

a. Select Corridors > Create > Template > Create Template, the Create Template window will appear.

b. Select File > Open > Site Modeling.itl [Metric - Site Modeling.itl]

c. Browse to Project Templates

d. Select EC-Cut Fill 6:1

e. Review the Template and note the origin point (set at 0,0) and the cut/fill tie down slopes are set for 6:1 and will tie to the existing 
terrain model which is set as the active terrain model.

f. Select Close after reviewing the template.
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2. Create the Tower Yard Slope Grading.

a. Select Model Detailing > 3D Tools > Apply Linear Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the tower yard geometry in View 1.

 Feature Definition: Final

 Name: Tower Yard Grading

 Template: Press <ALT> and the Down Arrow to open the template library. Select Project Templates\EC-Cut Fill 6:1 

 Left click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side Reflect Option: Move your cursor to the outside of the tower pad to set the reflection side. This will create the grading 
to the outside of the tower yard.

Tip: If the grading displays on the wrong side, the Properties dialog can be used to flip the Reflect option.

 Exterior Corner Sweep Angle: 05^00’00”

 Description: Tower Yard Grading

Tip: The interval and accuracy of a linear template is controlled by the stroking settings (as described on page 13).



Copyright © 2019 Bentley Systems, Incorporated 16DO NOT DISTRIBUTE - Printing for student use is permitted

3. Review the 3D Model

4. Now that the tower yard grading has been created let’s add all of the slope grading tie down features (construction limits) to the Tower 
Yard terrain model. Adding these features will give us a more complete terrain model that will include the slope grading features.

a. Select Terrain > Edit > Feature Management > Add Features

b. Following the heads up prompts (after each prompt, Left-click to 
accept values and move to next prompt):

 Locate Terrain Model To Add Elements: Select Tower Yard terrain 
in 3D Model

 Locate Element to Add: Select the Tower Yard Construction Limit 
feature in the 3D model.

 Locate Next Element to Add - Reset When Done: Right click

 Feature Type: Boundary

 Left click to accept.
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The slope grading tie down features are now added to the Tower yard terrain model. 
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Analyze Volumes

Before we continue designing the site, let’s take a quick look at analyzing preliminary cut/fill volumes between the existing ground 
terrain and the tower yard terrain.

1. Analyze the Cut/Fill Volumes by comparing the existing terrain to the Tower Yard terrain to see if we can reduce the amount of cut/fill.

a. Select Terrain > Analysis > Analyze Volumes

b. Follow the heads up prompts (after each prompt, Left click to accept values and move to the next prompt):

 Volume Method: Terrain Model To Terrain Model Volume

 Locate From Terrain Model: Select the Existing Terrain 

 Locate To Terrain Model: Select the Tower Pad

 Enter Cut Factor: 1.0

 Enter Fill Factor: 1.0

 Boundary: Reset for None

 Save Result: Yes

 Datapoint to Place Results: Left click in View 1 to place the results.

2. Review the results and notice the amount of Fill. We need to reduce the amount of fill so now we will lower the Tower Pad which will in 
turn lower the Tower Yard. 

Since rules and relationships exist between the terrain and the features used to create the terrain, simply adjusting the Tower Pad profile 
will update the terrain automatically.
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3. Adjust the height above ground of the tower pad profile.

a. Select Geometry > Vertical > Open Profile Model

 Locate Plan Element: Select the Tower Pad

 Select or Open View: Select or pick View 4 to open the profile model

4. In the Profile Model, select the Tower Pad profile element. Notice the dynamic text indicates the profile was created 4.0’ [1.2 m] above the 
existing terrain.

5. Left click on the dynamic text value 4.0 [1.2]

6. In the input field, key in a value of 3.0 [1.0] and Left click to accept.

The profile is now placed 3.0’ [1 m] above the existing terrain. Notice that the tower pad, tower yard elements and terrain automatically 
update maintaining the rules and relationships that were originally established.

7. Repeat Step 1 to analyze the volume and observe the reduction in fill.

In our case we only have fill volumes but the Analyze Volumes tool can also be used to help balance the cut and fill volumes between two 
terrains.
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Exercise 2: Create the Driveway

In this exercise, we will take a look at how to design and model the gravel driveway. 

Skills Taught
 Create edge of driveway profiles using Profile Intersection Points and Vertical Geometry tools

 Create driveway grading using Linear Templates

 Use Target Aliasing to seek the tower yard grading

 Add Clipping Reference to cleanup grading
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Creating the Driveway Profiles

In this section, we will take a look at how to design and model the gravel driveway. The driveway does not require a crown so we will 
not use the centerline of the drive to project slopes. We will create left and right edge profiles first that will help define the driveway 
cross slopes for this example. We'll build the edges linearly from the back of sidewalk to the tower yard.

1. Create the profile for the left edge of driveway

a. Select Geometry > Vertical > Open Profile Model

b. Follow the heads up prompts (after each prompt, Left click to accept values and 
move to the next prompt):

 Locate Plan Element: Select the left edge of driveway feature

 Select or Open View: Select or pick View 4 to open the profile model

We need to find the elevations where the edge of driveway intersects the tower yard 
and London Rd. back of sidewalk feature. The Profile Intersection Point tool will allow 
us to accomplish this task.

2. Select Geometry > Vertical > Profile Creation > Profile Intersection Point

a. Follow the heads up prompts (after each prompt, Left click to accept values and 
move to the next prompt):

 Locate Element to Show Intersection: Select the left edge of driveway feature

 Locate Element which Intersects: In the 2D view, select the back of walk corridor feature (the back of walk profile and 3D feature 
has already been established from the London Rd. corridor).

 Locate Element for Next Intersection - Reset To Complete: Select the tower yard geometry

 Locate Element for Next Intersection - Reset To Complete: Right click to complete

3. In the profile window, Select Fit View to better see the profile intersection points that are displayed on the profile.
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These steps generated two points in the profile which represent the location and elevation where the right edge of driveway intersects the 
London Rd. back of sidewalk feature and the Tower Yard. You may have to zoom in really close to see the points.

4. Select Geometry> Vertical > Lines > Profile Line Between Points

5. In the Profile Line Between Points dialog, set the Feature Definition to Road_EdgeOfPavement

6. In Name field, key in LT_Drive 

7. Follow the heads up prompts:

a. Enter Start Point: Snap to the left point, Back Of Walk.
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b. Enter End Point: Snap to the right point, Tower Yard

c. Select Geometry > Vertical > Set Profile Active

 Select Plan Element: Select left edge of driveway

 Select Profile Element: Select the left edge of driveway profile

8. Repeat the previous steps to create the right edge of driveway profile. Name the profile: RT_Drive and don’t forget to set it as the Active 
Profile so it displays in 3D.

9. Review the 3D Model and note the 3D features of the driveway edges now appear. 
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Adjust Tower Yard Grading

Before creating the driveway grading we will need to adjust the tower yard grading to better accommodate the gravel drive. In this 
exercise you will learn how to modify the limits of the linear template used for the tower yard grading.

1. Adjust the tower yard linear template grading limits

a. In View 1, select the Linear Template Drop (purple dashed line around the perimeter of the tower yard).

b. 2. Hover your cursor over the linear template drop until the context sensitive menu appears.

c. Select Properties to view the template properties

d. In the End Station field, key in 5+09.40 [0+155]

The tower yard linear template grading will update and the terrain model will also update.
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2. Review the 3D Model and notice there are still some contours present under the driveway which will create some unwanted overlap when 
we go to add the driveway elements to the tower yard terrain model. We’ll need to temporarily remove the tower yard construction limit 
feature from the terrain model before continuing.

3. Remove the Tower Yard Construction Limit feature.

a. Select Terrain > Edit > Feature Management > Remove Features

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Terrain Model To Remove Elements: Select Tower Yard terrain in 3D Model

 Locate Element to Remove: Select the Tower Yard Construction Limit feature in the 3D model.

 Locate Next Element to Remove - Reset When Done: Right click or Reset
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Add the Driveway Elements to the Terrain Model

Now we will add the edge of driveway elements created in the to the tower yard terrain model. 

1. Add the left and right edge of driveway elements to the Tower Yard terrain model.

a. Select Terrain > Edit > Feature Management > Add Features

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Terrain Model To Add Elements: Select Tower Yard terrain in 3D Model

 Locate Element to Add: Select the left edge of driveway element in View 1

 Locate Next Element to Add - Reset When Done: Select the right edge of driveway element in View 1

 Locate Next Element to Add - Reset When Done: Right click or Reset

 Feature Type: Boundary (this will prevent the terrain from triangulating outside of the driveway edges)

 Left click to accept.
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Create Driveway Slope Grading with Linear Templates

In this section, you will learn how to do the slope grading on the left and right side of the driveway using linear 
templates.

1. Create the right edge of driveway grading.

a. Select Model Detailing > 3D Tools > Apply Linear Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the right edge of driveway element

 Feature Definition: Final

 Name: RT_EOD Grading

 Template: Press <ALT> and the Down Arrow to open the template library. Select Project Templates\EC-Cut Fill Driveway

 Left click OK

 Start Station: Press <ALT> to Lock To Start

 End Station: 0+64.40 [0+019.30]

 Select Side Reflect Option: Toggle On (Move your cursor to the south, away from the right edge of driveway)

 Exterior Corner Sweep Angle: 05^00’00”

 Description: RT_EOD Grading
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2. Create the left edge of driveway grading.

a. Select Model Detailing > 3D Tools > Apply Linear Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the right edge of driveway element

 Feature Definition: Final

 Name: LT_EOD Grading

 Template: Press <ALT> and the Down Arrow to open the template library. Select Project Templates\EC-Cut Fill Driveway

 Left click OK

 Start Station: Press <ALT> to lock to start

 End Station: 0+64.40 [0+019.60]

 Select Side Reflect Option: Toggle On, (Move your cursor to the north, away from the left edge of driveway)

 Exterior Corner Sweep Angle: 05^00’00”

 Description: LT_EOD Grading
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Adjust Driveway Slope Grading

Now, we have the driveway grading we need to do a little cleanup work. By default the driveway slope grading ties down to the existing 
terrain model (active terrain model) but we need to make the grading tie down to other proposed grading objects on the project as well. 

In this section we will use Target Aliasing to force the driveway grading slopes to tie down to the tower yard grading and the London Rd. 
corridor grading. Target Aliasing allows you to target other corridors, terrains or features and to set up a prioritized target list for end condition 
solutions on terrains, corridors or features.

1. Define Target Aliasing

a. Select Corridors > Miscellaneous > Define Target Aliasing

b. Locate Corridor: Select the LT_EOD Grading Linear Template in View 1
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After selecting the corridor the Define Target Aliasing dialog will appear.

c. Set the Target to Proposed, as shown in the dialog above.

The left portion of the dialog displays a list of available terrains, corridors or features that you can target. The right portion of the dialog 
is where you define the Aliases (target terrains, corridors or features) and the processing order. When an end condition seeks a target 
it will start at the top of the Aliases list. If a target is not found the end condition will then work its way down the list until a target is 
found.

d. Locate Alias Entries:

Follow the heads up prompt and Locate Alias Entries to add to the Aliases list:

 In the 2D view, Select the London Rd. Corridor

 In the 2D view, Select the Tower Yard Grading Linear Template

Note: You can also pick these items from the list and use the Add-> button to 
add them to the Aliases list.

The selected corridors and terrain are now added to the Aliases list.

e. Click Apply and then close the tool.

The Linear Template will process and update based on the new target aliases 
you defined. In the areas where London Rd. and Tower Yard exist, the slope 
will tie down to those corridors. 
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2. Repeat the Steps 1 and 2 for the RT_EOD Grading linear template.

3. Review the 3D model to ensure the slopes are now tied to the Tower Yard and London Rd. corridors in the appropriate areas. In the areas 
where London Rd. and Tower Yard exist, the slope will tie down to those corridors. In the areas where those are not found the slopes will 
just default to the existing terrain model.
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Cleanup Areas of Overlap with Corridor Clipping

Now that the driveway grading ties to the appropriate corridors we still need to cleanup up the areas of overlap. We’ll accomplish this 
by clipping out overlapping portions of the grading where the driveway slope grading intersects the Tower Yard slope grading and the 
London Rd. slope grading.

1. Add the driveway slope grading as clipping references to remove grading overlaps with the tower yard.

a. Select Corridors > Miscellaneous > Add Clipping Reference > Corridor Clipping

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Corridor to Be Clipped: Select Tower Yard Grading linear template

 Locate Clipping Reference: Select LT_EOD Grading Linear Template

 Locate Next Clipping Reference - Reset To Complete: Select the RT_EOD Grading Linear Template

 Locate Next Clipping Reference - Reset To Complete: Right click to complete

A portion of the tower yard grading will be removed and the driveway grading will now blend in nicely with no overlaps in the model.
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2. Now that the tower yard grading has been cleaned up let’s add all of the slope grading tie down features (construction limits) to the Tower 
Yard terrain model. Adding these features will give us a more complete terrain model that will include the slope grading features.

a. Select Terrain > Edit > Feature Management > Add Features

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Terrain Model To Add Elements: Select Tower Yard 
terrain in 3D Model

 Locate Element to Add: Select the LT_EOD Grading 
Construction Limit feature in the 3D model.

 Locate Element to Add: Select the RT_EOD Grading 
Construction Limit feature in the 3D model.

 Locate Next Element to Add - Reset When Done: Select the 
Tower Yard Construction Limit feature in the 3D Model

 Locate Next Element to Add - Reset When Done: Right click

 Feature Type: Boundary

 Left click to accept.

The slope grading tie down features are now added to the Tower 
yard terrain model. 
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3. Review the 3D model and notice that the contours between the driveway edges have disappeared. This happened because we initially 
set the edge of driveway elements as a Boundary feature type in the terrain model. 

The boundary feature type is preventing triangulation between the driveway edges. We will now change the edge of driveway elements to 
be Breakline features, this will allow the terrain to triangulate between the driveway edges.

4. Change the edge of driveway elements to be a Breakline features.

a. Select Terrain > Edit > Feature Management > Change Feature Type

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Terrain Linear Feature: Select the left edge of driveway element

 Locate Next Feature To Change - Reset to Complete: Select the right edge of driveway element

 Locate Next Feature To Change - Reset to Complete: Right click or reset to complete

 Feature Type: Breakline

 Left click to complete
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5. Review the 3D model to ensure the contours are now displayed between the driveway edges.

Completed Tower Yard terrain model.

Although the Tower Yard is essentially complete. We still need to clip out a portion of the London Rd. slope grading where it overlaps the 
driveway entrance. We will use the same procedure described in step 1 of this section and apply corridor clipping to the London Rd. 
corridor which is referenced but in a different file.
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6. Open the London Rd. Corridor

a. Open the Corridor-London Rd.dgn [Metric-Corridor-London Rd.dgn] (Grading-Cell Tower site.dgn has already been attached as a 
reference for your use).

7. Add the Tower Yard terrain as a clipping reference to remove grading overlaps with London Rd.

a. Select Corridors > Miscellaneous > Add Clipping Reference > Corridor Clipping

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Corridor to Be Clipped: Select London Rd corridor

 Locate Clipping Reference: Select Tower Yard terrain model

 Locate Next Clipping Reference - Reset To Complete: Right click to complete

The portion of London Rd. that overlaps the driveway will now be removed.
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8. Review the 3D model.
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Apply Surface Template to Terrain Models

Now that the tower yard and driveway terrain models are complete we want to apply a material and thickness by using the Apply 
Surface Template tool. Apply Surface Template gives you the ability to add material depth and thickness to terrain models. In this 
exercise we will apply a 6” (152 mm) gravel surface template to the terrain model.

1. Open the Grading-Cell Tower Site.dgn [Metric-Grading-Cell Tower Site.dgn]

2. Turn Off Construction Elements in View 1.

a. Left click in View 1 to set it active.

b. Select View Attributes

c. Select Constructions, this will turn off the linear template element manipulators and handlers.

3. Apply a gravel surface template to the terrain models.

a. Select Model Detailing > 3D Tools > Apply Surface Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Terrain Model: Select Tower Yard terrain

 Apply External Clip Boundary: Yes (By using a clip boundary the surface template will only be applied to the portions of the terrain 
that are inside of the boundary and prevent the surface template from being applied to the side slope grading).

 Select External Boundary Element: Select the Tower Yard element

 Select Template - <ALT> Down To Browse Templates: Press <ALT> Down Arrow

 Select Surface Templates\Gravel

 Click OK to complete
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 Data Point to Accept selection: Left click to accept

The gravel surface template has now been applied to the Tower Yard area of the terrain model. Note how it applies thickness and 
material to the terrain model and the gravel surface template only appears within the external clip boundary. Utilizing the clip boundary 
prevents the surface template from being applied to the slope grading.
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Now we will use the same steps to apply a gravel surface template to the grave driveway areas of the terrain model. Use the driveway 
boundary element in View 1 as the external clip boundary.

4. Add Gravel Surface Template to the terrain model

a. Select Model Detailing > 3D Tools > Apply Surface Template

b. Locate Terrain Model: Select Tower Yard terrain

c. Apply External Clip Boundary: Yes

d. Select External Boundary Element: Select the Driveway Boundary element (a closed shape has been placed around the perimeter of 
the driveway on the level named Terrain_Surface Template Boundary).

e. Select Template - <ALT> Down To Browse Templates: Press <ALT> Down Arrow

 Select Surface Templates\Gravel

 Click OK to complete

f. Data Point to Accept selection: Left click to accept

The gravel surface template has now been applied to the terrain model. 
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Review Cross Sections

Now that the cell tower site is completed let’s take a look at how to review cross sections along the Line X alignment.

1. Select Corridors > Review > Open Cross Section View 

a. Locate Corridor or Alignment: Select the Line X alignment

b. Left Offset: -150 [45] (Be careful where you data point to 
accept the offset values because it changes the sign of the 
offset).

c. Right Offset: 100 [30]

d. Station: 2+00 [0+061]

e. Interval: 10 [3]

f. Select of Open View: Select View 7

A cross section should now appear.

Note: This cross section view window is showing dynamic cross sections extracted from the 3D model. All elements in the 3D model will 
appear in the cross section.
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2. Using the cross section navigation tool at the top of the cross section view window. Navigate through the cross sections to review the site.

3. Close the cross section view when finished reviewing the cross sections.
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Create a Combined Terrain Model from Multiple Terrains

In this section, we are going to combine the tower yard terrain model with other terrain models on the project to form one single terrain. We will 
utilize the Create Complex Terrain Model tool to accomplish this. This tool allows you to combine, merge and append multiple terrains into one 
single ruled terrain model. It also allows you to control the merging order of the terrains used to create the complex terrain model.

1. Open Terrain-Combined Project Site.dgn [Metric - Terrain - Combined Project Site.dgn]. 

Note this is a 3D file and we will be working exclusively in 3D for this particular exercise and all necessary terrain models for the project 
have been attached as references. 
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2. Create Combined Project Terrain Model

a. Select Terrain > Create > Additional Methods > Create Complex Terrain Model

b. Set the Current Action to Merge

c. Using the Element Selection tool, select the London Rd. Terrain, Forest Ct. Terrain and Tower Yard Terrain 

d. Left click From Selection Set > (this will add the terrains to the Process Order portion of the dialog). 

Make sure the London Rd. is first in the list and the Merge/Append option is set to Primary. Also, make sure Forest Ct is second in the 
list the Merge/Append option is set to Merge and Tower Yard is third on the list.

e. Set the Feature Definition to Terrain\Proposed\Proposed Triangles

f. Name: Combined Project Site

g. Left click Finish to complete.

3. Turn off all reference files to better view the terrain model you just created.

a. Select the Home > Primary > Attach Tools > References 

b. Select all reference files EXCEPT the Terrain_Existing Ground.dgn

c. Select the reference display button to turn off all of the selected references

d. Close the References dialog



Copyright © 2019 Bentley Systems, Incorporated 45DO NOT DISTRIBUTE - Printing for student use is permitted

4. Review the completed terrain model.
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Add this point we are done with merging the project terrain models into one terrain but sometimes it’s necessary to merge the project 
terrain model with the existing ground as well.

5. Edit the Complex Terrain Model to add the existing terrain to the complex terrain model.

a. Select Terrain > Edit > Edit Complex Terrain Model

b. Select the complex terrain, left click to accept it

c. Select the Existing_Terrain from the left side of the dialog

d. Click Add to add it to the processing list

e. Use the Up and Down arrows to adjust the processing order as shown below

f. Click Apply to finish

6. Turn off the Terrain_Existing Ground.dgn reference file to better view the terrain model you just created.

a. Select the Home > Primary > Attach Tools > References 

b. Select the Terrain_Existing Ground.dgn

c. Select the reference display button to turn off all of the selected references

d. Close the References dialog
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7. Review the completed terrain model.
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Additional notes:
The Create Complex Terrain Model tool is used to merge or append multiple terrain models into one. Order is important as the models are 
processed in the order listed. It is also crucial to specify append or merge as appropriate for the project, as the results may be dramatically 
different. Both merging and appending combines the data contained in multiple (two or more) models. However, they are not the same 
process and yield different results. 

When appending, the software triangulates the combined data from the two terrain models using all data from both models and ignoring none. 
The two models may overlap or be adjacent to one another. If there is data in both models in a common area, it is all utilized for triangulation. 

When merging, the software triangulates the combined data from the two terrain models in areas where they do not overlap. The two models 
must overlap at least one point. If there is data in both models in a common area (overlap), the data from the primary model is discarded, and 
only the data from the merging model is used. Therefore, order is critical. Any two terrain models can be merged together as long as one 
terrain model overlaps the other model in at least one point. A warning message is displayed if there is no overlap, and no processing occurs. 

Another thing to note is that the complex terrain we created is a rule based terrain meaning that rules and relationships exist between all of the 
terrains. If those terrain models were to change the complex terrain model will update. 

One final thing to add, do not detach the reference file! Since the complex terrain was created from terrains located in a reference file, 
detaching the reference file will break the rules and relationships that exist within the complex terrain.
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Exercise 3: Create Infield Pond Between Multiple Corridors

In this part of the course we will learn how to create a Stormwater Management (SWM) pond in an infield area of an 
interchange.

Skills Taught
 Pond modeling

 Create pond terrain model

 Analyze Slopes and Elevations
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Pond Layout

In this part of the course we are going to investigate how to create and model Pond in an infield area between multiple 
corridors. We will use some of the same tools and techniques that we used in part 1 of this course. The Pond layout and 
typical section are shown below and should be used for reference.
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Create Pond Profile

In this section we will create a profile that represents the water elevation of the pond. The water elevation of the pond will be set at 
154.0 [47.0]. The boundary of the pond water has already been created using civil geometry. We will use the Profile By Constant 
elevation to assign the elevation to the pond water boundary.

1. Open Grading-Infield Ramp A.dgn 

a. Select Open.

b. Browse to c:\Bentley Training\Site Modeling and Non-Corridor Modeling or other folder where you unzipped the dataset files.

c. Open the file named Grading-Infield Ramp A.dgn [Metric-Grading-Infield Ramp A.dgn]

2. Create pond profile using Profile By Constant Elevation tool

a. Select Geometry > Vertical > Element Profiles > Profile By Constant Elevation 

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate First Element: Select the Pond boundary element

 Feature Definition: Linear\Site\Site Pond

 Name: Pond Water

 Locate Element Reset End: Right click or reset 

 Elevation: 154.00 [47.0]

 Left click to complete. 

3. Left click in View 4 to make it the active view.

4. Select Fit View
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The pond water profile will now be displayed in the Profile Model in View 4. 

5. Set the Pond Water profile as the active profile so it will display in the 3D Model.

a. Select the newly created profile in View 4 and hover your cursor over the profile until the context menu appears.

b. Select Set As Active Profile to assign the profile to the Pond Water element.

The 3D feature of the pond water will now be displayed in the 3D Model. 
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Create Pond Grading

In this exercise, we will assign a pond grading linear template to the pond horizontal geometry. The linear template we 
are going to use has all of the pond grading elements built into it (berm and sideslopes) and it will generate all of the 
grading features in 2D and 3D.

1. Review the Pond Grading Template.

a. Select Corridors > Create > Create Template, the Create Template window will appear.

b. Select File > Open > Site Modeling.itl [Metric - Site Modeling.itl]

c. Browse to Project Templates\Pond Grading

d. Select Pond Grading

e. Review the Template and note the origin point is the Water 
Elevation and the following design parameters are built into 
the template:

 The pond bottom is set 4’ [1.2] feet below the water 
elevation

 Pond side slopes are set at 3:1 below water, 4:1 above 
water

 Freeboard is set 2’ [0.6 m] above water elevation

 Maintenance Berm is 12’ [3.2] wide at 2%

 Cut and Fill tie down slopes are set for 8:1 and will tie down 
to the infield terrain model which is set as the active terrain 
model.

f. Select Close after reviewing the template.
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2. Create the Pond grading by applying a Linear Template to the Pond element

a. Select Model Detailing > 3D Tools > Apply Liner Template

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: Select the pond element in View 1

 Feature Definition: Final

 Name: Pond Grading

 Template: Press <ALT> and the Down Arrow to open the template library. Select Project Templates\Pond Grading

 Left click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side Reflect Option: Move your cursor to the outside of the pond to set the reflection side

 Exterior Corner Sweep Angle: 05^00’00”

 Description: Pond Grading
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3. Turn off the levels named Site Grading and Site Pond in the 3D model and review the 2D model and 3D model. 

When the linear template is applied to the pond it’s important to note that linear features (template geometry) are created in 2D as well as 
3D. These features can be used to create a terrain model of the pond. To better see the linear features in 2D, turn off the construction 
elements and the Grading-Infield Ramp A.dgn (Default-3D) reference file.

4. Turn off Construction Elements in View 1.

a. Left click in View 1 to set it active.

b. Select View Attributes

c. Select Constructions, this will turn off the linear template element manipulators and handlers.

5. 5. Turn off the Grading-Infield Ramp A.dgn (Default-3D) reference file

a. Select the Home > Primary > Attach Tools > References 

b. Select the Grading-Infield Ramp A.dgn (Default-3D)

c. Select the reference display button to turn off the selected reference file

d. Close the References dialog
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Create Pond Terrain Model

Now that the pond grading is complete we are going to create a terrain model of the pond and pond water so that we 
can analyze the pond volume.

1. Create the Pond Terrain model from elements.

a. Using the Element Selection tool, select the 
following pond features in the 2D or 3D view:

 Pond Berm Tie

 Pond Berm In

 Freeboard

 Pond Water

 Pond Bottom

b. Select Terrain > Create > From Elements

c. Following the heads up prompts (after each 
prompt, Left-click to accept values and move to 
next prompt):

 Datapoint to Add 5 selected elements

 Feature Definition: Terrain\Proposed\Proposed Contours and Triangles

 Name: Pond

 Feature Type: Breakline

 Edge Method: None
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2. Change the Pond Berm Tie element to a Boundary to clean up extraneous triangles.

a. Select Terrain > Edit > Feature Management > Change Feature Type

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Terrain Linear Feature: Select the Pond Berm Tie element

 Locate Next Feature To Change - Reset When Complete: Right click or reset to complete

 Feature Type: Boundary

 Left click to complete

3. Analyze the Pond Volume by comparing the Pond terrain model to the Pond Water Elevation of 154.0 [47.0].

a. Select Terrain > Analysis > Volumes > Analyze Volumes

b. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Volume Method: Terrain Model To Plane

 Locate From Terrain Model: Select the Pond terrain model

 Enter To Plane: 154.0 [47.0]

 Enter Cut Factor: 1.0

 Enter Fill Factor: 1.0

 Boundary: Reset for None

 Save Result: Yes

c. Datapoint to Place Results: Left click in View 1 to place the results.
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Create Complex Terrain Model of the Pond and Ramp A Infield

In this section, we will create a combined terrain model of the Pond and Ramp A Infield using the create complex terrain 
model tool.

1. Open Terrain-Combined Infield.dgn [Metric - Terrain - Combined Infield.dgn]. 

2. Create Combined Terrain Model of the pond and infield

a. Select Terrain > Create > Additional Methods > Create Complex Terrain Model

b. Set the Current Action to Merge

c. Using the Element Selection tool, select the Ramp A Infield terrain and the Pond terrain

d. Left click From Selection Set > (this will add the terrains to the Process Order portion of the dialog). 

Make sure the Infield terrain is first in the list and the Merge/Append option is set to Primary. Also, make sure the Pond is second in 
the list the Merge/Append option is set to Merge.

e. Set the Feature Definition to Terrain\Proposed\Proposed Triangles

f. Name: Combined Infield

g. Left click Finish to complete.



Copyright © 2019 Bentley Systems, Incorporated 59DO NOT DISTRIBUTE - Printing for student use is permitted

3. Turn off the Grading-Infield Ramp A.dgn reference file to better view the complex terrain model just created.

a. Select the Home > Primary > Attach Tools > References 

b. Select the Grading-Infield Ramp A.dgn (Default-3D)

c. Select the reference display button to turn off the selected reference file

d. Close the References dialog

4. Review the 3D model and note that the infield and pond grading terrains are now combined to form one single terrain model.

5. Adjust the complex terrain properties to display only the contours.

a. Select any of the terrain model triangles in the 3D model, hover your cursor over the terrain until the context menu appears.

b. Select Properties

c. Set the Feature Definition to Terrain\Proposed\Proposed Contours
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6. Review the 3D model.
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Analyze Terrain Model

Sometimes it’s necessary to review the elevation, slope, distance and delta information between two selected points of a terrain model or 
mesh. In this exercise we will use the Analyze Between Points and Analyze Point tool to review this information.

1. Rotate the 3D View to Top View.

a. Select View > Top View

2. Analyze Slopes and Elevations Using Analyze Between Points tool. 

a. Select Terrain > Analysis > Points > Analyze Between 
Points

b. Select Terrain Model Element: Select any contour line

c. Select Start Point: Left click anywhere inside of the infield 
terrain model

d. Move your cursor anywhere within the infield terrain and 
notice the heads up display. 

The heads up display shows the elevation, slope, 
distance and delta elevation from the start point and to 
end point of where your cursor is located. The results 
change dynamically as you move around. Slope text is 
also attached to the end point of your cursor displaying 
the current slope. This slope text can be placed directly 
into the file.

e. Left click anywhere within the infield terrain to the place 
the slope text.

Note: The graphics are placed in the 3D Model. In order to delete them, you must go the 3D Model.
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3. Analyze a single point in the terrain model.

a. Select the Terrain > Analysis > Points > Analyze Point tool to Analyze Elevation and Slope of a point within the terrain model.

b. Select Terrain Model Element: Select any contour line

c. Move your cursor anywhere inside of the terrain model, the slope and elevation will display and dynamically change as you move your 
cursor.

d. Left click anywhere inside of the terrain to place the slope and elevation text.
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4. Analyze Trace Slope to visualize the path of a drop of water within the terrain

a. Select the Terrain > Analysis > Hydraulic > Analyze Trace Slope 

b. Select Terrain Model Element: Select any contour line

c. Move your cursor anywhere inside of the terrain model, elevations and elevation difference will display and dynamically change as you 
move your cursor.

d. Left click anywhere inside of the terrain to place the trace slope path graphically in the file.
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