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Introduction to OpenSite Designer 
for Civil 3D Users
This course is suitable for the 2020 Release 1 (10.08.00.88) version of:

OpenSite Designer CONNECT Edition
OpenRoads Designer CONNECT Edition
OpenRail Designer CONNECT Edition

About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos for 

this course are available through CONNECT Advisor and on the LEARNserver (learn.bentley.com).

 This PDF file includes bookmarks providing an overview of the document. Click on the bookmark to quickly jump to 
any section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. For example: 12’ 
[3.4m] 

 This course workbook uses the Training and Examples workspace delivered with the software.

 The terms Left-click, Click, Select and Data are used interchangeably to represent pressing the left mouse button. 
The terms Right-click and Reset are also used interchangeably to represent pressing the right mouse button. If your 
mouse buttons are assigned differently, such as for left-handed use, you will need to adjust accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can 

Course Level: Fundamental

http://learn.bentley.com
http://learn.bentley.com
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OpenSite Designer Overview

OpenSite Designer is a new application that employs an open modeling environment for the project delivery of site design projects from 
concept to completion. The application provides complete detailed design capabilities for rapid site modeling and analysis, earthwork 
optimization and quantification, drainage and underground utility design, automated project deliverables, and more. 

OpenSite Designer provides the most comprehensive site design workflow available including reality modeling, geotechnical, underground 
utilities, stormwater drainage, terrain modeling, detailed drawing production, and visualization. 

Using OpenSite Designer you can:

 Assemble context data rapidly from a variety of sources, such as point clouds, 3D reality meshes, terrain data, images, and geospatial 
information to bring real-world settings to your project. 

 Achieve exponential modeling performance gains with the model-centric production of design deliverables. 

 Enable users to share project information across teams, locations, and disciplines with precision and security. 

 Use Catalog Services to manage and deliver functional components for consistent generative design across the engineering team. 

 Access Documentation Center to produce multi-discipline documentation for all work on assets across the project. 

 Share realistic visualizations with the public and stakeholders to gather feedback, improve public engagements, and speed project 
approvals. 

Key Capabilities
 Optimize Site Layout 

Simplify site layouts with designer-defined parametric drawing capabilities. 

 Optimize Earthwork 

Employ a highly advanced optimization engine for earthwork allowing designers to quickly and easily explore alternatives. The 
grading solver runs thousands of iterations based on designer-defined constraints for each site layout to find the best cost of 
construction. 

 Perform Design-Time Analysis 

Ensure visibility into overall project performance with design-time analytics to achieve optimized design outcomes for a wide 
variety of analysis such as drainage, terrain, safety, grading, site visibility, and more. 
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Course Overview

This workbook is designed to help users understand the basic tools within OpenSite Designer. Users will learn workflows for creating a site 
project and also learn about using the automation and optimization tools for grading.

The complete site design is shown below. We will begin with the conceptual horizontal layout of the site by creating the project site limits, the 
building footprint, parking lots, main drive and connector drives.

Once the conceptual horizontal layout is complete we will run the Grading Solver which will optimize the grading for the site and also define 
the elevations of the 3D site elements.

This workbook contains “compatibility notes” which are denoted with this icon . The notes are intended to assist in the transition to 
OpenSite Designer from Civil 3D. These notes are formatted to stand out from other text in the body of the document. 

Civil 3D and AutoCAD are trademarks or registered trademarks of Autodesk, Inc. All other brands and products are trademarks of their 
respective owners.
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OpenSite Designer Workflow

The typical OpenSite Designer workflow is listed below.

1. Import or Attach an existing terrain model and property data as reference files to the design file.

2. Create 2D horizontal layout of the proposed site using specially designed site layout tools.

3. Run the Grading Solver to perform grading optimization of the site.

 The Grading Solver is a very powerful and useful tool that will analyze the horizontal layout against the existing terrain and determine 
the optimized grading. The Grading Solver also automatically creates the vertical geometry and 3D features of the site design.

4. Review and analyze the grading, contours and 3D model.

5. Revise site features as needed.

6. Change Phase to Final.

A fundamental concept for new users to understand is that OpenSite Designer stores all of the site design elements in the design file. As 
you place elements rules and associations are being created based on the default site design values that are set in the Site Layout 
Settings. 

Also, OpenSite Designer is designed to work with reference files. For example, the surveyor may deliver the existing ground terrain in a 
separate .dgn file and the architect may deliver the building footprint in a separate .dgn or .dwg. These files can be easily referenced into 
your design file to use as a starting point for your site design.

 The .dgn file is the design file format similar to the .dwg file in Civil 3D. All civil design elements are stored in the .dgn file.
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Exercise 1: Getting Started

In this exercise, you will learn to start the software, select the proper WorkSpace & WorkSet, open a design file, review the interface, review 
design file settings, define a geographical coordinate system, import existing ground data, attach reference files, set the active terrain model 
and define 2D & 3D Model Views.

Skills Taught
 Start the Software

 Select WorkSpace and WorkSet

 Create a Design File (.dgn)

 Review the Ribbon Interface

 Review Design File Settings

 Define Geographical Coordinate System

 Import Existing Ground LandXML file.

 Attach Existing Terrain and GIS Parcels Reference Files

 Set Active Terrain Model

 2D and 3D Model Views
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Start the Software and Create a Design File

In this section you will start the software, set the WorkSpace & WorkSet and create a design file.

1. Start the software.

2. Set the WorkSpace and WorkSet

The WorkSpace and WorkSet define standards that are used by the software. The Workspace defines the agency/company wide 
standards and the WorkSet is used to define project specific standards. The WorkSpace and WorkSet used for this training are installed 
during the software installation.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down menu.

3. Create a new 3D design file.

a. Select New File.

b. Change the Save in folder to C:\Bentley Training\Introduction to OpenSite Designer for Civil 3D Users or other folder where you 
unzipped the dataset files.

Click the down arrow to the right of the folder to Browse

c. Click the Browse button to the right of to the Seed field. It opens to the workspace-defined seed folder: 
C:\ProgramData\Bentley\OpenSite Designer CE\Configuration\Organization-Civil\_Civil Default Standards - Imperial\Seed\

d. Select Seed3D - Imperial Design.dgn [Metric-Seed3D - Imperial Design.dgn].

 The seed file is used as a template to set design file settings such as the Drawing Units, Levels, etc.
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e. Type Terrain_Existing.dgn [Metric-Terrain_Existing.dgn] in the File Name field.

f. Click Save. The file will now be created and will open.
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Navigating the Interface

Tools can be accessed a variety of ways, including the familiar Ribbon interface. Ribbons are arranged by Workflows, which are selected from 
a pull-down in the upper left corner of the software. In this section, we will take a look at the interface.

1. Activate the OpenSite Modeling workflow from the pick list in the upper left corner if it is not already active. 
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The ribbon menu will reflect the OpenSite Modeling tools. The tools are organized into categories on the ribbon tabs.

 Home - Common tools such as Attributes, Explorer, Attach Reference Tools, Models, Level Display and Element Selection.

 Note the OpenSite Help tool in the upper right corner of the ribbon. (Home > OpenSite Help > OpenSite Help)

 Terrain - Element selection and terrain modeling tools.

 Geometry - Element selection, Civil AccuDraw and geometry tools including Lines, Arcs, and Points.

 Site Layout - Element selection and specialized groups of tools for site layout and design (Draw Basic, File Import, Parking, Pad, 
Pathway, Vertical Geometry, Grading Proposed and Modify Phase).

 Template Modeling - Element selection, superelevation and corridor modeling tools.

 Model Detailing - Element selection, Civil Cells and 3D tools (Linear Templates, Surface Templates, etc.)

 Drawing Production - Element selection, saved views, notes, text, annotations, and plans production (cross section, plan, and profile) 
tools.

 Drawing - Commonly used MicroStation drawing tools. To the complete set of MicroStation tools change the active workflow to 
Drawing, Modeling (3D only) or Visualization (3D only).

OpenSite Designer includes all of the functionality of MicroStation CONNECT Edition, much the same way Civil 3D includes all 
of the functionality of AutoCAD.

 View - Commonly used view control tools.

2. Click on each of the Ribbon tabs and notice how each tab has a different set of tools.

The Quick Access Toolbar to the right of the Workflow drop down list contains 
common tools like Create New File, Open File, Save Settings Compress File, 
Undo, Redo, Print, Explorer and Properties. It is easily customizable.
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A Search Ribbon tool is also available at the right side of the title bar. Use it to find tools 
across the multiple ribbons. When you are not sure where to find a tool, simply type the 
command in the Search Ribbon field and a search will be performed across all ribbon 
menus.

Shown to the right are results for a search for Parking.

3. Search for a tool using the search ribbon. Key in Parking in the Search Ribbon field.

4. Notice the results of the ribbon search are displayed in a dialog below the Search 
Ribbon field.

5. Click on Show Details in the bottom right corner of the dialog, the tool list will be 
expanded and the description of the tools are now shown.
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6. Hover over Parking Lot

The search results expand, showing where the Parking Lot tool is located in the 
ribbons: OpenSite Modeling -> Site Layout -> Parking. You may have different or 
additional paths.

Clicking on the OpenSite Modeling -> Site Layout -> Parking path will open the tool.

7. In the Search Results dialog, Left-click Parking Lot to open the Place Parking tool.

8. Right-click to close the toolbox.
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9. Introduction to the Back Stage View.

a. Activate the Back Stage View by clicking File in the ribbon menu.

The Back Stage View will appear.

Notice the various options on this screen such New, Open, Save, Save Settings, Settings, Help, etc. Some of these “File” tools are 
available from the Quick Access Toolbar, but the bulk of the File capabilities are here. 
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b. Select Settings.

Settings are broken up logically. User, System, File and Configuration all have corresponding tools here. This keeps the ribbon menus 
focused on the engineering and production tools.
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Reviewing the Working Units and Civil Formatting

After creating a new file it is a best practice to review the Working Units, Civil Formatting and Geographic Coordinate System are defined 
correctly. In this section, you will learn how to review the working units and civil formatting.

1. Review the Working Units.

a. Navigate to Settings > File > Design File Settings

b. Select Design File Settings, the Design File Settings dialog will appear.
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c. Select the Working Units category.

d. Review the Linear Units and Advanced Settings. The Linear Units settings are used for coordinate readout and display. The Advanced 
Settings control the units of resolution and the overall working area size of the design file. 

e. Change the Sub Unit to US Survey Feet and change the Label to the foot symbol ‘ as shown in the image above.



Copyright © 2020 Bentley Systems, Incorporated 16DO NOT DISTRIBUTE - Printing for student use is permitted

2. Review and change the Civil Formatting Coordinate Settings to Northing, Easting.

a. Select Civil Formatting. This is used to control the formating and display of civil geometry elements.

b. Change the Coordinate Settings format to Northing, Easting.

c. Click OK to exit the Design File Settings.

d. Select Save Settings so that the changes you made are saved to the file.
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Define the Geographic Coordinate System

Defining a Geographic Coordinate System is essential for properly locating the project in the world. Our site project is located in California so 
we need to define the proper Geographic Coordinate System for the site. In this section, you will learn how to define the geographic 
coordinate system.

1. Attach a Geographic Coordinate System.

a. Select the Drawing workflow from the drop down menu. 

b. Select the Coordinate System tool under the Utilities tab and Geographic group.

 We can see that the Geographic Coordinate System (GCS) has not been set. We created this file from the seed file: 3D Imperial 
Design.dgn which had no GCS set. Our project is in California so we will need to set the appropriate GCS.

 The Geographic Coordinate System lets the software know were the project is located geographically and what coordinate system 
needs to be defined for the project. They allow local finite coordinate systems to conform to global standards for global data 
synchronization. For example, Bing Maps show up seamlessly with the proper GCS applied to a file.

 The Geographic Coordinate System tool is somewhat similar to the Set Location tool in Civil 3D.
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2. Change the Geographic Coordinate System to NAD 1983 StatePlane California III FIPS 0403 Feet

a. In the Geographic Coordinate System dialog, select From Library

b. When the Select Geographic Coordinate System window appears, select the Search tab.

c. In the Search Text field key-in: EPSG:102643. 

d. Click the Find Now button, the software will search the Geographic Coordinate System library and return its results when finished.

e. Select EPSG:102643

f. Click OK. The geographic coordinate system will now be attached.

g. Close the Geographic Coordinate System dialog.

h. Select Save Settings located at the top of the Ribbon.



Copyright © 2020 Bentley Systems, Incorporated 19DO NOT DISTRIBUTE - Printing for student use is permitted

Import LandXML file and Create the Terrain Model

A majority of site projects must start with an existing ground surface. OpenSite surfaces are called Terrain Models. Terrain model data is 
stored and managed in a 3D design file. For this course we are going to import existing ground data from a LandXML file into the design file 
to create the existing ground terrain model. 

The LandXML file was created by exporting a Civil 3D Tin Surface. Civil 3D Surfaces and Alignments can be imported into OpenSite 
Designer via LandXML.

1. Import existing ground data from LandXML file. 

a. Change the Workflow to OpenSite Modeling.

b. Select Terrain > Create > From File (the Select Files to 
Import dialog will now appear). 

This tool is similar to the Civil 3D tool  Import 
LandXML.

c. Select the Terrain_Existing.xml file

d. Select Done. The Import Terrain Model dialog will 
appear.

e. In the Feature Definition panel, set the Feature 
Definition to Existing Contours by selecting the drop 
down arrow to view the Feature Definition list.
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f.  

 Feature Definitions are similar to Styles in Civil 3D.

g. Select Terrain\Existing\Existing Contours

Selecting the Feature Definition defines how the terrain model will be displayed once it is imported. In this case, the existing contours 
will be displayed.

h. Be sure Build Terrain From is set to Source and Definition and Import Options is set to Import Terrain Only.
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i. Select Import to import the file.

j. Close the Import Terrain Model(s) dialog.

k. Select Fit View to view the existing terrain 
model.

2. Before we continue, lets be sure that the terrain model data was imported into the right place geographically. A good way to check this is 
to turn on the Background Map in the view (internet connection required to display background map).

a. Select View Attributes.

b. Expand the Background Map panel by clicking the down arrow.
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c. Set the Background Map Type to Aerial.

The aerial image will be automatically shown and you will see that the survey data lines up quite nicely as expected. The aerial image 
is being pulled from Bing Maps (internet connection required) and is utilizing the geographic coordinate system that is assigned to this 
design file. 

 This functionality is similar to the Set Location tool in Civil 3D.

d. After you have confirmed the terrain model is in the correct location. Turn OFF the background map by setting the type to None.
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Set up the Working File

In this section, you will learn to attach the existing terrain model (i.e. existing topography) and GIS parcel data as reference files. We 
will use these files to help layout the site. It is a best practice to attach terrain models as reference files when you need to use them for 
site design.

1. Select Open (located at the top of the ribbon).

2. Browse to C:\Bentley Training\Introduction to OpenSite Designer for Civil 3D Users and Select Site-Model.dgn [Metric-Site-Model.dgn] 
(this is a blank 2D file that we will use for designing our site. Before we begin we will need to attach the existing terrain model and GIS 
parcel data).

Note: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. 
Clicking Yes will align the file to the software you are using (OpenRoads or OpenRail Designer). This will have zero impact for training. 
Note that in production, upgrading the file will make the file read-only in OpenSite Designer. Full information is available at Bentley 
Communities - Product Realignment.

3. Attach the existing terrain model file.

a. From the ribbon menu select Home > Primary > Attach Tools > References 

 This tool is similar to the Attach Reference tool in Civil 3D.

b. Select Attach Reference .

c. Select the file 
Terrain_Existing.dgn [Metric-
Terrain_Existing.dgn]

d. Set Attachment method to 
Coincident World.

e. Select Open to attach the file 

The Terrain_Existing.dgn will 
now appear in the References 
dialog. 

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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4. Review the existing terrain.

a. Click in View 1 to make it active and select Fit View.
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5. Using the References tool, attach the GIS_Parcels.dgn file.

a. Select Attach Reference 

b. Select the file GIS_Parcels.dgn 

c. Set Attachment method to Coincident World.

d. Select Open to attach the file.

The GIS_Parcels.dgn is now attached.

e. Close the References dialog.
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6. Turn On the Background Map Aerial Imagery.

a. Select View Attributes.

b. Expand the Background Map panel by clicking the down arrow.

c. Set the Background Map Type to Aerial.

d. Adjust the Transparency so that the parcels and contour lines are more visible.
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The next thing we need to do is set the terrain model active so the software knows that the existing terrain stored in the 
Terrain_Existing.dgn will serve as the foundation of our site design.

7. Set the Terrain Model Active.

a. Select the Element Selection tool from Home > Selection > Element Selection 

 This tool is similar to using your mouse to select elements in Civil 3D.

b. Set the Element Selection tool to individual mode by selecting the individual and new icons.

c. Click anywhere on the terrain model boundary. Hover your cursor at this location for a few seconds until the context sensitive menu 
appears.

d. Select Set As Active Terrain Model. 

 This command is similar to setting the Base Surface in Civil 3D.

Note: Setting the Terrain Model active will automatically create a 3D Model if one does not already exist in the active design file.

Next we will set up 2D and 3D views and review the 3D model.

1. Set up 2D and 3D Views
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a. In the View 1 Right-Press (a held Right-click) to access the Context Menu. Select View Control > 2 Views Plan/3D

 This command is actually a macro defined in the workspace that sets up the two views’ models, size and other properties. Pressing 
F9 also runs this macro.

 Notice the view windows will now have a 2D View and a 3D View. Any View can view any Model in the dgn. 

 View 1 is the Default 2D model and View 2 is the Default-3D model (created automatically when you set the terrain model active). 

 Having both a plan (2D) view and a view of the 3D model visible provides robust feedback to your design steps. Any time there is 
3D information associated with elements, it will be displayed in the Default-3D model.

TIP: Always pay attention to which model is the active model.

2. Review the existing terrain model. 

a. Review the existing terrain model displayed in View 2. The active terrain model can be viewed in the 3D Model. It is also referenced 
into the 2D model as well. What you see in View 1 is actually a reference of the 3D Model.

b. Close View 2, since we will not be working with anything in the 3D model just yet. We will deal with creating 3D elements later in the 
course.

c. Maximize the View 1 window.



Copyright © 2020 Bentley Systems, Incorporated 29DO NOT DISTRIBUTE - Printing for student use is permitted

Exercise 2: Design Site Layout

In this exercise, you will learn how to create a site plan consisting of the site project limits, parking lots, building footprint, main drive and 
connecting drives. The exercise will also cover how to make some object revisions.

Skills Taught
 Create Site Project Boundary

 Create Building Footprint

 Create and Edit Main Drive

 Create and Edit Parking Lots

 Review Site Layout Settings

 Review Site Feature Properties with Explorer

 Create and Edit Parking Lot Drive Connectors
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Create Site Project Boundary

In this section you will learn how to create the site project boundary by picking property points. The site project boundary is created using a 
tool called Limits of Disturbance. The boundary can be creating by graphically picking points, flooding an existing shape or picking a previous 
drawn shape.

1. Define the site project boundary using property points as a guide.

a. Select Site Layout > Grading Proposed > Limits of Disturbance

b. Set the Feature Definition to: Site_Boundary_LOD 

c. Set the Name Prefix to: BND_LOD 

d. Follow the heads-up prompts: 

 Method: Pick Points

 Enter First PI: Use the image below as a guide. Beginning in the southwest corner 
and moving in a clockwise direction, start picking the property points drawn in the file.

 Once the last point is selected, click right mouse button to create site project limits.
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Once the property boundary has been placed you’ll notice setback lines have also been created (the setback lines are drawn as dashed 
lines). 

As site features are placed, rules and relationships known as Design Intent are being formed. Design Intent allows for the intelligent updating 
of features as you make changes. Now we will learn how to make some simple changes.
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The next thing we need to do is adjust the Setback Distance to match zoning requirements. 

2. For this project change the Building Setback Distance to 10.0 [3 m] and Parking Setbacks distances to a value of 5.0 [2 m]. 

a. Using the Element Selection tool, select the site project limits.

b. Zoom into the southwest corner of the project limits until you see the parking and setback distances.

c. To change the setback distances, click on each setback text value and key-in new values. You will have to do this for every value 
displayed for each setback.

d. Continue changing setback distances by working your way around each side of the site project. You will have to zoom in and out as 
you go along.

e. Be sure to change the value for both the parking and building setback distances.
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The completed adjusted site project limits should now look like the image below.



Copyright © 2020 Bentley Systems, Incorporated 34DO NOT DISTRIBUTE - Printing for student use is permitted

Create Building Footprint

Depending on the type of project a desired building footprint may be known. For this project were are going to reference a footprint that was 
designed in OpenBuildings and provided to us by the Architect. The building footprint is geolocated and will be located at the Architect’s 
desired location.

1. Using the References tool, attach the Bldg_Footprint.dgn file.

a. From the ribbon menu select Home > Primary > Attach Tools > References

b. Select Attach Reference.

c. Select the file Bldg_Footprint.dgn.

d. Set Attachment method to Coincident World.

e. Select Open to attach the file.
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2. Now that the building footprint has been attached we need to define the building footprint with OpenSite Modeling tools.

a. Select Site Layout > Pad > Building

b. Set the Feature Definition to Building Footprint > Site_Building

c. Set the Name Prefix to BLDG

d. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Pick the southwest corner of the building to place the first PI 
point.

 Enter Next PI/Back Radius: Continue clockwise and pick the northwest corner 
of the building to place the second PI point.

 Enter Next PI/Back Radius: Pick the northeast corner of the building to place 
the third PI point.

 Enter Next PI/Back Radius: Pick the southeast corner of the building to place 
the third PI point.

e. Right click to complete.

f. Right click again to exit the command.

3. Now that the building footprint has been defined we can turn off the building footprint 
reference file.

a. Select Home > Primary > Attach Tools, the References dialog will appear.

b. Select the Bldg_Footprint.dgn

c. Select the Display tool to turn off the reference file.

d. Close the References dialog.
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Create Main Drive

For this project there will be a main drive that runs through the project starting at the intersection to the north and terminating into the roadway 
on west side of project. In this section, you will learn how to create the main drive.

1. Layout the driveway using the image as a 
guide. You may need to zoom in to see more 
detail of the aerial image.

a. Select Site Layout > Pathway > Driveway

b. Set the Feature Definition to Driveway > 
Site_Driveway_Light_Duty_Full_Depth_As
phalt

c. Set the Name Prefix to DRIVE

d. Follow the heads-up prompts and using the 
aerial image as a guide:

 Method: Pick Points

 Enter First PI: Pick starting point being edge of pavement at the intersection on the north boundary of project. 

 Enter Next PI/Back Radius: Move your cursor southwest approximately 200’ [60] to place the second PI point.

Note: As you drag the cursor, you get bearing and distance feedback.You can adjust the 
Background Transparency and the Heads Up Display text size and color to make the feedback 
clearer (File > Settings > User > Preferences >> View Options - Civil >>  Manipulator Settings).

 Enter Next PI/Back Radius: Move your cursor southwest and parallel with the property line 
approximately 200’ [60] to place the third PI point.

 Enter Next PI/Back Radius: Move your cursor northwest and parallel to the south building face 
and pick the edge of pavement as the last PI point.

e. Right click to complete.

f. Right click again to exit the command.
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2. Now that the drive has been placed, change the radius for each curve to 50’ [15].

a. Select the drive, the dynamic text manipulators will now be displayed and available for in-place editing. 

Also, note the drive width values and graphical manipulators along the driveway centerline. The graphical manipulators allow you to 
move the driveway as needed. The triangle manipulators give you access to the design properties for the left and right side of the 
driveway. You can use those manipulators to make changes to the default design values (i.e. change lane width, cross slope, add 
tapers, medians, etc).

b. Hover your cursor over the curve PI manipulator until the radius manipulators appear.

c. Click on the radius value manipulators (they will be displayed as 0) and change them to 50’ [15].

The centerline geometry will update and the edges of the driveway will now follow the updated geometry.
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Create Parking Lots

For this project there will be two parking lots with two drive connectors. This exercise will go through how to create parking lots and how to 
place and revise drives.

1. Layout the parking lot using the image as a guide.

a. Select Site Layout > Parking > Parking Lot

b. Set the Feature Definition to Parking Lot > 
Site_Parking_Light_Duty_Full_Depth_Asphalt

c. Set the Name Prefix to PRK_LOT

d. Follow the heads-up prompts and using the aerial image 
as a guide:

 Method: Pick Points

 Enter First PI: Pick the southeast corner of the 
building.

 Enter Next PI/Back Radius: Move your cursor parallel 
along the back face of the building and pick a point on 
the building setback line.

 Enter Next PI/Back Radius: Move your cursor 
southeast along the property line a distance of 
approximately 180’ [55].

 Enter Next PI/Back Radius: Follow the main drive to south until first turn and pick next point. 
 Enter Next PI/Back Radius: Follow the main drive to the southwest and set point in line with south side of building

e. Right click to complete and right click again to exit the command. 

The parking lot design will be automatically created based on design standards that are defined in the Site Layout Settings. These 
settings can be changed at anytime during the design process.
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2. Now that the main parking lot area is complete we will now place a front parking lot area. Use the image below as a guide.

f. Select Site Layout > Parking > Parking Lot

g. Set the Feature Definition to Parking Lot > Site_Parking_Light_Duty_Full_Depth_Asphalt

h. Set the Name Prefix to PRK_LOT_FRONT

i. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Pick the southwest corner of the building.

 Enter Next PI/Back Radius: Following along the west face of the building pick the northwest corner of the building.

 Enter Next PI/Back Radius: Set the next point approximately 60.1’ [18] from the previous point.

 Enter Next PI/Back Radius: Next create the western side of parking by drawing the next segment 159’ [48] long at a right angle 
from previous segment.

j. Right click to complete and then Right click again to exit the command.
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3. The short end of front parking area needs to revised to remove parking 
spaces. 

a. Zoom in to the northeastern edge of the front parking lot

b. Select the 3 space parking area. Once selected the dynamic text will 
appear.

c. Hover your cursor over one of the parking space elements, the 
Properties tool will appear.

d. Select Properties.

e. In the Properties panel, change Has Parking from True to False. This will remove parking stalls along north edge of parking.

The Properties tool can be used to make changes to any site feature at any time. Notice the various fields available for editing (Has 
Aisle, Aisle Width, Has Curb, Curb Height, etc.) simply click in the property field that you would like to adjust and the site feature will 
update automatically.
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f. Repeat the process to remove the 3 parking spaces along the southern edge of the parking lot.

When we first placed the parking lot you may have noticed we didn’t enter any design or layout information. We simply drew some shapes and 
all of the parking spaces, islands and aisles where created automatically in a logical manner. This is by design. OpenSite has predefined 
design standards and layout properties that are configured in the Site Layout Settings. 
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Review Site Layout Settings in Explorer

The default design standards and layout settings for the parking lot are defined in the Site Layout Settings which can be found in the OpenSite 
Standards panel in the Explorer. OpenSite Standards is similar to the Settings tab in Civil 3D. The Site Layout Settings contains all of the 
default rules for how site objects and features get built. 

1. Open Explorer and review the Site Layout Settings for the 
parking lot.

a. Select Explorer (located in the upper left corner of the 
ribbon).

b. Navigate to OpenSite Standards pane and expand the 
pane by clicking on the down arrow.

c. Expand the Standards category by clicking the arrow on 
the left.

d. Select Site-Model.dgn (Default) and expand the list until 
you can see the Site Layout Settings.

e. Expand Site Layout Settings until you see all of the site 
settings as listed in the image to the right. 

This area is where all of the design standards and layout 
settings are defined for the various site objects.

2. Review the design standards and layout settings for the 
Parking Lot Area.

a. Select Area category listed under Parking Lot Default 
Properties.

b. Right click and select Properties to review the design 
standards and layout settings for the parking area.

c. Close the Properties pane.
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Review Site Objects in Explorer

As you build site objects and features they are managed and organized in the OpenSite Model within the Explorer tool. The OpenSite 
Model gives you detailed information and access to each site object and its associated features. 

 The Explorer and OpenSite Model are similar to the Prospector tab in Civil 3D.

1. Review Site Objects.

a. Navigate to the Explorer tool on the left side of the screen.

b. Click on the down arrow to the right of the OpenSite Model panel to expand the panel.

c. Expand Site Layout. You will now be able to see all of the OpenSite object categories near 
the bottom of the list.

d. Click the arrow next to each site object category to further expand the list until you see all of 
the site objects that make up our site.

e. Select the site object named BLDG, this is the building object. Notice that when you select 
the object it highlights in View 1. 

Most site projects have several site objects and these objects sometimes can be hard to 
find in the design file. Simply selecting objects from the list makes it easy to locate in the file 
for when you need to make changes.

f. Right click on BLDG and select Zoom to. The BLDG object will highlight and the view will 
zoom in and center on the building object.

The right click functionality can also be used to dig deeper into a site elements design 
parameters to make changes via the Properties tool.

g. Right Click on BLDG and select Properties. Note the design properties: Phase, Grading, 
Feature, Building, Type, etc. Any of these design parameters can be changed at any time 
and the layout will automatically update.

h. Close the Properties pane.
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Drive Connector from Parking Lot to Main Drive

With Main Drive and Parking Lots created a connection point between the two need to created. The driveway tool will be used to make this 
connection.

1. Select Site Layout > Pathway > Driveway

a. Set the Feature Definition to Driveway > 
Site_Driveway_Light_Duty_Full_Depth_Asphalt

b. Set the Name Prefix to DriveConn1 

c. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Using the mid-point snap, pick the mid-point along the 
southern edge of the front parking lot.

 Enter Next PI/Back Radius: Using the nearest snap, pick a point on 
the main drive along the north edge of the drive.

d. Right click to complete.

e. Right click again to exit the command.

Note: The drive will be created using design settings found in the Site Layout Settings. The Site Layout Settings contains all of the 
default rules for how site objects and features get built.
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2. Repeat the same process to create a drive that connects the rear parking lot at the mid-point to the main drive. 

a. Set the Feature Definition to Driveway > Site_Driveway_Light_Duty_Full_Depth_Asphalt

b. Set the Name Prefix to DriveConn2 

c. Follow the heads-up prompts:

 Method: Pick Points

 Enter First PI: Using the mid-point snap, pick the mid-point along the eastern edge of the rear parking lot.

 Enter Next PI/Back Radius: Using nearest point snap, pick a point on main drive along the north edge of the drive.

d. Right click to complete.

e. Right click again to exit the command.

Note: If your drive does not display it is because there is not enough room between the main drive and the parking lot. You will have to 
move the parking lot edge to the west a few feet in order to construct the drive.

3. If the drive did not display, follow the steps on the next page to adjust the parking lot.
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4. Review the Parking Lot and move the eastern edge of the parking lot a little farther west away from the main drive.

a. Using the element selection tool, select the Parking Lot.

b. Hover your cursor over the diamond shaped manipulator near the mid-point along the eastern edge of the parking lot. This allows you 
to adjust either the inside or outside of the parking lot.

c. Select the arrow that points toward the inside of the parking lot and move it a few feet west to create more space between the parking 
lot and main drive. Use the image above as a guide.

 The entire parking lot will update and the new connector driveway will appear now.

 If the new connector driveway does not appear, you may need to place another drive between the parking and main drive.
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5. Change the radius returns at the parking lot.

a. Select the end of the drive located at edge of the parking lot. A circle will 
highlight the point at the end of connection line. 

b. Select this circle manipulator.

c. Hover the cursor over the circle and select Properties.

d. The Properties panel will show design controls for the drive point.

e. Change the Entrance Flares Radius to 2.

f. Change the Exit Flare Radius to 2. The radius returns will update.

6. Change the radius returns at the main driveway.

a. Select the end of the driveway located at the edge of the main driveway. A 
circle will highlight the point at the end of connection line. 

b. Select this circle manipulator.

a. Hover the cursor over the circle and select Properties.

b. The Properties panel will show design controls for the drive point.

c. Change the Entrance Flares Radius to 2.

d. Change the Exit Flare Radius to 2. The radius returns will update. 

The length of the driveway will also adjust. You may need to extend the 
driveway using the manipulators if the radius returns undisplay.
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Exercise 3: Project Grading

In this exercise you will learn about optimized grading performed by the Grading Solver.

Skills Taught
 Grading Solver

 Optimize Project Grading
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Project Grading

With the conceptual site plan complete, the next step is to create the grading for the project. Grading will allow a better understanding of 
feasibility of the conceptual layout. 

1. Open 3D Model View and create the project grading.

a. Press F9 on your keyboard, this will open 3D Model in View 2. Currently, the only 3D data that exists in the 3D model is the existing 
terrain. 

We are now going to run the Grading Solver which will analyze the conceptual horizontal layout against the existing terrain and 
determine the optimized grading and also create vertical geometry and 3D features of the conceptual design.

b. Select Site Layout > Grading Proposed > Grading Solver

Once selected another window will open to show the site going through grading optimization.
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Once the grading optimization is complete the results will be displayed in the Landscape 3D Viewer and 3D features will be created in the 
3D Model. The optimized cut and fill quantities are also displayed in the lower right portion of the screen.

The Landscape 3D Viewer is used to analyze the results of the grading optimization. 

2. Review the grading optimization results in the Landscape 3D Viewer window. 

a. Select the Boundary and Contours toggle at the bottom of the viewer to change the display to a color coded representation of the 
design.

The toggles at the bottom of grading 
viewer will control what information is 
shown.

 Type of Surface show (i.e. 
Graded, original, graded & 
original, etc.)

 Surface Triangles

 Surface

 Boundaries (colored 
representation of design)

 Contours

 Scale

 Lower right hand corner shows 
amount of earthwork being done.

b. Press the letter C on your keyboard to 
see a rough cost estimate.
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3. Review the Contours and 3D Model.

Notice the 3D Model does not show a lot detail. This is because all of the site elements were placed using the default Phase of 
Concept (only terrain models will be created for each site object). To see a more a detailed 3D model you need to change the Phase 
for each site object from Concept to Preliminary (terrain models with surface templates will be created) or Final (terrain models with 
surface templates and linear templates will be created). 

OpenSite elements can placed as: Concept, Preliminary or Final. 

 Concept and Preliminary are tied directly to the grading solver. As you make changes the grading solver will still optimize the site.

 Final is used to fine tune the design and allows the user to make user defined changes that does not affect the results of the 
grading solver. 
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Exercise 4: Project Finalization

So far, our model has been about 

 the speed of layout, 

 the ability to make very, very fast changes to the horizontal design,

 the software balancing all the object constraints to provide and optimum grading design.

We’ve reached a milestone in our workflow: we have the foundation for a balanced design that meets our design criteria, but we don’t have all 
the detailed construction elements in place yet.

At this milestone we will change the fluid, easily-modified concept model to one that has the fully-detailed objects that can be constructed. We 
do this by changing the Phase from Concept to Final.

While we still can move elements back to the highly fluid Concept Phase, it is a Best Practice to Archive this milestone as a “Return To” point. 
Save As or the command line “Backup” are ways to do so.

Once in the Final Phase, we can review the new more-detailed 3D features and perform detailed engineering such as Applying Linear 
Templates.

Skills Taught
 Archive your Conceptual Milestone

 Change the Phase to Final

 Review 3D Model and Cross Sections

 Linear Templates
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Archive your Conceptual Milestone

Here we’ll save our design with a name that will be clear to other designers or after a long period of time.

Naming your file

This is no time to name this file Site-Model.bak, or <Project Number><discipline code>.dgn - unless you’re in an environment like ProjectWise 
where you can associate a long Description. File names can be long: use them to make it clear what’s going on in the file. Consider a name 
like ARCHIVE-<ProjectName>SiteModel-MainDrive2Lots.dgn

 ARCHIVE (or other office-wide convention for an Archive file) alerts to the purpose of the file and makes a good search term.

 The Description describes what the model looks like. Very often you will try a different alternative, perhaps adding parking across the 
main drive. 

 It’s okay - and recommended - that when you archive a later alternative that you rename the original so that the name adequately 
describes the original with respect to later alternatives. 

The overall guideline is to make it clear, from the filename itself, what is going on in the file in a way that a different designer could infer what 
distinguishes the file from the current finished file.

Backup

The keyin backup creates a file with the current name and the extension .bak.

1. Click Home > Primary > Key-in

2. In the Key In field, type backup.

3. Confirm that the backup file is created: you will 
see a message stating so in the Message bar.

Backup is quick and easy, but it overwrites any 
backup file with the same name without prompting 
you. 

You can create backups frequently, but it is recommended that your rename important milestones so that they don’t get overwritten. 

We’ll skip going to the Windows Explorer to rename the file, but know that you do have a milestone archive right now, even if it is poorly 
named.
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Save As

Note: If you use Save As to create a new file, you will want to return to the original file (rather than work in the newly-named archive file).
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Change the Phase to Final

1. Change the Phase to Final

a. In View 1, using the element selection tool, select all of the site elements (You should have a total of six elements).

b. Select Modify > Modify Phase

c. Select Final.

When you select Final, terrain models and surface templates are applied to the site elements and you now get a more detailed 3D 
model.
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Review the 3D Model

Review the 3D Model. Now you will see more detail. You will see that the building footprint will have a concrete material 
thickness and the driveway and parking lot will have asphalt material thickness. The materials can be easy quantified 
since they are 3D elements.
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Review with Cross Sections

To get a better look at the material thicknesses and grading. Let’s take a look at a cross section through the site.

1. To view a cross section you must first place a reference line or alignment across the site.

a. Left click in View 1.

b. Select Geometry > Horizontal > Lines > Line Between 
Points

c. Set the Feature Definition to Alignment > 
Geom_Baseline

d. Set the Feature Name to Ref Line

e. Follow the prompts and use the image below as a guide 
to the place the reference line:

 Enter Start: Select a point near the mid-point of the 
existing western roadway.

 Enter End: Select a point to the east of the main 
drive.

2. Create the Cross Section

a. Select Template Modeling > Dynamic Sections

b. Follow the heads-up prompts:

 Locate Corridor or Alignment: Select the reference line.

 Left Offset: -200 [60], press Enter to lock the value.
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 Right Offset: 200 [60], press Enter to lock the value.

 Station: 0+90 [0+030], press Enter to lock the value.

 Interval: 50 [10], press Enter to lock the value

 Select or Open View: Select View 8 from the view control buttons at the bottom of the screen.

 Data point or Left Click in View 8.

The cross section will now be displayed in View 8.

What you see in the cross section window is a “slice” through the 3D model. Any 3D element displayed in the 3D model will be 
shown in the cross section. Also, note the curb, parking lot and main drive all have material thickness. This material thickness 
comes from surface templates that are applied to the terrain models for each of these site elements.

c. Use the navigation buttons to scroll through the cross sections.

Notice that we don’t have any grading that ties to existing ground on the right side of the main drive. We will address this by adding a 
Linear Template along the south edge of the main drive.
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Apply a Linear Template 

Linear Templates are used to model 3D components along linear elements. They can be simple or very sophisticated, 
using full “End Condition” capabilities of the OpenRoads cross section modeling technologies. Here we will Apply a 
Linear Template along the south edge of the main drive.

1. Select Template Modeling > Apply Linear Template

a. Following the heads up prompts (after each prompt, Left-click to accept values and move to next prompt):

 Locate Element to Apply Template: In the 2D view or 3D View, select 
the CURB_BACK_TOP feature (i.e. top back of curb).

In the 2D View, you may need to turn off the Constructions in the View 
Attributes to better see the CURB_BACK_TOP feature.

 Feature Definition: Linear Template > Final

 Name: Grading

 Template: Press <ALT> and the Down Arrow to open the template 
library. The Pick Template window will appear.

 Browse to the Site Layout > Linear Templates > End Conditions folder 
and select Simple Tie Slope and click OK

 Start Station: Press <ALT> to lock to start

 End Station: Press <ALT> to lock to end

 Select Side - Reflect Option: Move the cursor away from the main drive 
southern edge so the grading is created on the outside.

 Exterior Corner Sweep Angle: Do not change the setting. 

 Description: Grading

Tip: If the grading displays on the wrong side, the Properties dialog can be used to flip the Reflect option.
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2. Review the 3D Model and Cross Sections.

NOTE: The Linear Templates can be used to complete the grading for the rest of the project by simply applying them to the other 
CURB_BACK_TOP features.
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Task - Practice What You Have Learned

Now that you have learn about the fundamental concepts of OpenSite Designer. Take some time using the horizontal 
layout tools to do the follow tasks in the specified order.

1. Create a New File and attach the existing terrain model and any other reference files.

2. Create a Site Project Boundary using the Limits of Disturbance tool.

3. Place a rectangular parking lot any size but large enough to construct a building and main driveway.

4. Place a building somewhere inside of the parking lot.

5. Place an L-shaped driveway through the parking lot.

6. Run the Grading Solver to optimize the site.
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Summary

In this course, you have now learned the fundamental tools within OpenSite Designer.

You have learned how to:

 Create a Design File (.dgn)

 Review the Ribbon Interface

 Review Design File Settings

 Define a Geographical Coordinate System

 Import Existing Ground Data via LandXML file

 Attach Existing Terrain and GIS Parcels Reference Files

 Set Active Terrain Model

 2D and 3D Model Views

 Create Site Project Boundary

 Create Building Footprint

 Create and Edit Main Drive

 Create and Edit Parking Lots

 Review Site Layout Settings

 Review Site Feature Properties with Explorer

 Create and Edit Parking Lot Drive Connectors

 Use the Grading Solver

 Optimize Project Grading

 How to Modify the Phase

 Review the 3D Model and Cross Sections 

 Apply Linear Templates
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